Dungeon boosting woes


I'm slowly working on my F2P monk. I got to the point of needing to do Eye of Azshara for the ilvl 50 belt. Since I can't queue on that toon, I just did the usual boost from my main account. However I kept running into an annoying problem. The usual method of just put on follow to the main toon wasn't working. From the point of view of my 50 the F2P toon just kept making really awkward movements and then would quickly stop following. It ended up not being a big deal because in EoA I could just use my chopper mount and carry my F2P toon along.

But just to test I tried this in Legion VH, Stockades, and Hellfire Ramparts and I didn't have the problem. Everything worked fine. But when I tried Darkheart Thicket, I had the same problem as EoA. So I guess my question is, is there some kind of annoying tech like phasing or something screwing this up that I can't think of?

Edit: I also just noticed I didn't get the achievement for Eye of Azshara or Darkheart Thicket. Weird.
Last edited:

Users who are viewing this thread